Bug report #17530

3d: not possible to use linestrings with z coordinates

Added by Nyall Dawson over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:3D
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25427

Description

Currently it's not possible to use linestrings with z coordinates in the absolute height mode.

This is because linestrings are buffered using geos at qgsline3dsymbol_p.cpp:121 - which resets all z values to 0. I'm not sure what the best approach here is. Potentially we could loop through the vertices in the buffered geometry, finding the closest corresponding vertex in the original linestring, and assigning its z value to the buffered geometry.

History

#1 Updated by Martin Dobias over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in QGIS 3.4 with the "simple" 3D line symbol.

Also available in: Atom PDF