Bug report #17503

Custom CRS is duplicated in 2.99

Added by Harel Dan almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Projection Support
Affected QGIS version:master Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25400

Description

User defined CRS, the name and parameters are duplicated several times, and appear as duplicate rows when setting project crs or editing the crs in the setting.

dup1.png (52.4 KB) Harel Dan, 2017-11-21 09:44 AM

crs2.png (35.5 KB) Harel Dan, 2017-11-21 02:41 PM

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High

#2 Updated by Nyall Dawson almost 3 years ago

  • Status changed from Open to Feedback

This should be fixed since last week - can you ensure that you're running a recent build, and then try removing all the duplicate entries and checking if they come back?

#3 Updated by Harel Dan almost 3 years ago

I have updated to the most recent build 95cf299099 and the issue indeed appears to be fixed.
At first I had 6 duplicates. After deleting them and rebooting QGIS, they did not reappear.

#4 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF