Bug report #17439

Rendering problems - objects randomly appears and disappears

Added by Darek Bobak almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:Yes
Operating System:Windows 10 Pro, Polish version Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25336

Description

When zooming in and out, objects in map randomly disappears and shows again.

I'm usually installing a new version of QGIS from OSGEO4W installer daily, the problem appeared two days ago.

I'm attaching sample project and spatialite database.

sample.zip - QGIS project and spatialite database (3.4 MB) Darek Bobak, 2017-11-09 09:54 PM

gonebabygone.mp4 (2.26 MB) Mathieu Pellerin - nIRV, 2017-11-13 04:02 AM

History

#1 Updated by Darek Bobak almost 3 years ago

I've checked the last version without this bug, its:

QGIS version
2.99.0-Master
QGIS code revision
df0d717f92
Compiled against Qt
5.9.2
Running against Qt
5.9.2
Compiled against GDAL/OGR
2.2.2
Running against GDAL/OGR
2.2.2
Compiled against GEOS
3.5.0-CAPI-1.9.0
Running against GEOS
3.5.0-CAPI-1.9.0 r4084
PostgreSQL Client Version
9.2.4
SpatiaLite Version
4.3.0
QWT Version
6.1.3
PROJ.4 Version
493
QScintilla2 Version
2.10.1
This copy of QGIS writes debugging output.

#2 Updated by Jürgen Fischer almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

#3 Updated by Mathieu Pellerin - nIRV almost 3 years ago

Jürgen, are you sure this is fixed? I still see this issue on my build (linux) which includes the referred commit.

Attaching a video of the (rather scary) issue. The features randomly going missing are the dark pink ones.

It's been affecting QGIS master for several months now.

#4 Updated by Darek Bobak almost 3 years ago

With the latest update from OSGEO4W the problem is fixed (at least, for me).

#5 Updated by Jürgen Fischer almost 3 years ago

Mathieu Pellerin - nIRV wrote:

Jürgen, are you sure this is fixed? I still see this issue on my build (linux) which includes the referred commit.

I wasn't seeing it on Linux. And on Windows I bisected it to 49de489c09db539968b494f020599ca02ba253dc - before fef56184bc032482, after that it's gone for me.

#6 Updated by Mathieu Pellerin - nIRV almost 3 years ago

Jurgen, OK, all good.

The issue captured in the video has to do with joined fields; ignore my noise ;)

Also available in: Atom PDF