Bug report #17375

Print Composer ignores width values from expression

Added by zimirrr leonid over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.14.17 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25272

Description

Hello. I found strange thing.

I have a project where lines width is calculated with such expression:
"width_coefficient" + to_real( @TEST_VAR_WIDTH )
where "width_coefficient" is column and @TEST_VAR_WIDTH global variable in qgis.

Here how layer looks like when @TEST_VAR_WIDTH = 0

And now @TEST_VAR_WIDTH = -0.5

Everything works fine but when I try to print as pdf from composer I get all lines.
See export_pdf.pdf

I've created test qgis project with one layer and composer. You can try it yourself.

QGIS version 2.14.17-Essen
Compiled against Qt 4.8.5
Compiled against GDAL/OGR 2.2.1
Compiled against GEOS 3.5.0-CAPI-1.9.0

step2.jpg (32.4 KB) zimirrr leonid, 2017-11-01 05:19 PM

step1.jpg (56.4 KB) zimirrr leonid, 2017-11-01 05:19 PM

export_pdf.pdf (42.2 KB) zimirrr leonid, 2017-11-01 05:21 PM

qgis_bugtrack_error.zip (31.2 KB) zimirrr leonid, 2017-11-01 05:22 PM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

what about 2.18.14/master?

#2 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF