Bug report #17297

Overwriting environment variables with custom variables in Options -> System does not work

Added by Andreas Neumann 11 months ago. Updated about 1 month ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:Yes
Operating System:Windows 7 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No

Description

When one overwrites an environment variable that is defined on the system level with a custom variable defined by the user (in Menu Settings --> Options --> System --> Environment) the new value is picked up, but not correctly used.

Example: define variable PGSYSCONFDIR centrally on the system, overwrite it with a custom PGSYSCONFDIR variable on the user level. In the list of "Current environment variables" the new custom value correctly shows up, but the old value before overwriting is still used.

See also screenshot attached

It is a regression. It worked fine on 2.18x

qgis_custom_env_vars.png - QGIS custom env vars (110 KB) Andreas Neumann, 2017-10-17 03:58 PM

History

#1 Updated by Nyall Dawson 7 months ago

  • Status changed from Open to Feedback

I can't reproduce - for me they are definitely working as intended (windows 10).

Is this still an issue?

#2 Updated by Giovanni Manghi about 1 month ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF