Bug report #17292

Data Source Manager: WFS loads layer two time if you use the Add button, and then click OK

Added by Richard Duivenvoorde 11 months ago. Updated 10 months ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No

Description

When in the Datasource manager you create a new WFS connection (via the WFS tab in the dialog),
and then connect to the service.
And then select one layer, and click Add, the layer is added.
BUT if you then click OK, the same layer is added again.

Screenshot added, using this url:
https://geodata.nationaalgeoregister.nl/cbsgebiedsindelingen/wfs?request=GetCapabilitiesx%x%

doublew.png (224 KB) Richard Duivenvoorde, 2017-10-16 09:31 PM

History

#1 Updated by Giovanni Manghi 11 months ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

#3 Updated by Alessandro Pasotti 11 months ago

  • Assignee set to Alessandro Pasotti

This is a feature, not a bug.

BTW, I'm strongly considering to revert the commit that removed the "Close" button and rename existing buttons to:

[Add] [Add and Close] [Close]

Where:
- Add: add the layer(s) to the canvas
- Add & Close: as "Add" plus close the dialog
- Close: just close the dialog

#4 Updated by Richard Duivenvoorde 11 months ago

In my opinion [Add] and [Close] is enough. But do as you (or others) prefer.

Thanks for fixing this feature ;-)

#5 Updated by Alessandro Pasotti 11 months ago

  • Status changed from Open to In Progress
  • Easy fix? changed from No to Yes
  • Regression? changed from Yes to No
  • Pull Request or Patch supplied changed from No to Yes
  • Priority changed from High to Normal

#6 Updated by Alessandro Pasotti 10 months ago

  • Resolution set to fixed/implemented
  • Status changed from In Progress to Closed

Also available in: Atom PDF