Bug report #17259

QGIS3 New node tool lack the ability to add or remove vertices from the current selection

Added by Dominique Lyszczarz almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25157

Description

With the new node tool it's possible to select multiple vertices by drawing a rectangle but its not possible to add or remove vertices from the current selection by maintaining ctrl or shift key and drawing another rectangle. Old node tool has this feature.

Associated revisions

Revision dd739ac0
Added by Nyall Dawson over 2 years ago

[needs-docs] Allow adding and remove nodes from node tool selection

Holding shift while clicking and dragging adds nodes to selection,
holding ctrl removes nodes from selection.

Additionally, this commit:
- fixes the current 'select node but don't start moving' shortcut,
but changes it from ctrl-click on a node to shift-click on a node
(since it's 'adding' to the selection)
- makes ctrl-click on a single node remove just that node from
the selection

Fixes #17259

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Tracker changed from Feature request to Bug report
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Priority changed from Normal to High
  • Regression? set to Yes

#2 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF