Feature request #17228

switch between simple and batch process dialogs, back and forth

Added by Harrissou Santanna almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GUI
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:25127

Description

Currently, when you hit the "Run as Batch Process..." button in a Processing tool dialog, you switch to the Batch processing interface. But there's no way (other than opening a new dialog) to go back to that simple process interface either because:
- hitting the "run as batch process..." was just a test
- you do not remember what to fill in a column or whether it's optional and needs to check that in the simple interface (the help frame doesn't seem available in batch mode)
- or you finally decide you just want to run the tool on a single file
- ...

Could hence be nice to have ability to switch between the two interfaces: the "Run as Batch Process..." could be renamed into "Switch to Batch Process..." and "Swith to unique (or simple?) Process..." according to the active window. And when switching from batch to unique, use the first row when filled to fill the dialog.

History

#1 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #16893

Also available in: Atom PDF