Bug report #17224

Smoothing (vigra) shown in processing but not working (osgeo4w packaging issue?)

Added by Alister Hood almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:2.18.13 Regression?:No
Operating System:Windows (10) Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25123

Description

Running QGIS from osgeo4w I tried to use the Saga processing algorithm "Smoothing (vigra)", and got the following:

\Users\alistair\AppData\Local\Temp\processing3c6f85ae910d4ceb9db91e391d1a23f6\c30f8a4a1a614b97a13520381ccf26e6\OUTPUT.sdat"
____________________________


##### ## ##### ##
### ### ## ###
### # ## ## #### # ##
### ##### ## # #####
##### # ## ##### # ##
____________________

SAGA Version: 2.3.2 (64 bit)


69 loaded tool libraries (640 tools):
- climate_tools
- contrib_perego
- db_odbc
- db_pgsql
- docs_html
- garden_3d_viewer
- garden_fractals
- garden_games
- garden_learn_to_program
- garden_webservices
- grid_analysis
- grid_calculus
- grid_calculus_bsl
- grid_filter
- grid_gridding
- grid_spline
- grid_tools
- grid_visualisation
- imagery_classification
- imagery_isocluster
- imagery_maxent
- imagery_photogrammetry
- imagery_segmentation
- imagery_svm
- imagery_tools
- io_esri_e00
- io_gdal
- io_gps
- io_grid
- io_grid_image
- io_shapes
- io_shapes_dxf
- io_table
- io_virtual
- pj_georeference
- pj_geotrans
- pj_proj4
- pointcloud_tools
- pointcloud_viewer
- shapes_grid
- shapes_lines
- shapes_points
- shapes_polygons
- shapes_tools
- shapes_transect
- sim_cellular_automata
- sim_ecosystems_hugget
- sim_erosion
- sim_fire_spreading
- sim_hydrology
- sim_ihacres
- sim_qm_of_esp
- sim_rivflow
- statistics_grid
- statistics_kriging
- statistics_points
- statistics_regression
- ta_channels
- ta_compound
- ta_hydrology
- ta_lighting
- ta_morphometry
- ta_preprocessor
- ta_profiles
- ta_slope_stability
- table_calculus
- table_tools
- tin_tools
- tin_viewer

type -h or --help for further information

Error: select a library

C:\OSGeo4W64\bin>exit
Converting outputs
Loading resulting layers

The following layers were not correctly generated.
Output
You can check the log messages to find more information about the execution of the algorithm

A bit of googling indicates that vigra is an optional dependency of saga, and I see someone else has this in their list of tool libraries, but I don't:

- imagery_vigra

Presumably this means vigra is not included in the osgeo4w build. Is it an oversight? Or is this just the way processing works? i.e. it shows every possible tool, but they may not all be included in a standard install, and the user has to try them to find out. If so, should this this explained somewhere obvious? The error messages are cryptic enough that users are likely to just think "qgis is broken" and move on.

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF