Bug report #17184

QGIS under macOS is very crashy when loading zipped shapefiles

Added by Giovanni Manghi about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:2.18.9 Regression?:No
Operating System:macOS Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:25083

Description

Try load a zipped shapefile (from "add vector layer") in QGIS under macOS and while it won't happen all the time is very frequent to have crash. Sometime you have to load the same zip twice (or load a different one).

albu.zip (178 KB) Giovanni Manghi, 2017-09-22 11:56 AM

Associated revisions

Revision cee7baeb
Added by Larry Shaffer almost 3 years ago

Crash when multiple .zips are loaded via qgisapp function (fix #17184)

Note: not just QObject::deleteLater(); see QgsDataItem::deleteLater()

History

#1 Updated by Giovanni Manghi about 3 years ago

The application used to compress the data does not seems to be a factor.

#2 Updated by Larry Shaffer almost 3 years ago

Issue replicated and fixed for me here on macOS 10.11.6:
https://github.com/qgis/QGIS/pull/5307

#3 Updated by Giovanni Manghi almost 3 years ago

  • Pull Request or Patch supplied changed from No to Yes

#4 Updated by Giovanni Manghi almost 3 years ago

Thanks Larry!

#5 Updated by Anonymous almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF