Bug report #17146

Processing: GRASS64 does not work in both latest 2.14 and 2.18

Added by Giovanni Manghi over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/GRASS
Affected QGIS version:2.18.12 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25045

Description

Despite being old and being dropped in QGIS3, in QGIS LTR (2.14 and 2.18) there is still all the necessary for GRASS64 support in Processing.

NOTE: why is important. Is important because in GRASS7 there is no r.mapcalculator module, and the attempt to make work r.mapcalc never worked. So in processing there is no really robust tool for map algebra (SAGA tool suffer some problems of its own).

Unfortunately for some reason this has stopped to work (while support for GRASS7 is ok):

Processing returns the usual message saying that GRASS64 is not installed, but it is. In fact if I "shortcut" the check (based on a test run of v.voronoi) in GrassUtils.py the tools do open as expected. The problem is that then the tools do not produce any output as it seems there is a problem while importing the data in the temporary location/mapset. It seems to be a quoting problem in importing modules.

History

#1 Updated by Alexander Bruy over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This is packaging issue. GRASS 6 needs GDAL 1.11 which is not installed by default and not listed as the package dependency. I have added GDAL 1.11 as dependency to the GRASS 6 package.

#2 Updated by Giovanni Manghi over 2 years ago

Brillant! thanks!

Also available in: Atom PDF