Bug report #17142

DB Manager: error when adding a raster from GPKG

Added by Giovanni Manghi about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25041

Description

This was observed on master with ones of the GPKG samples:

http://www.geopackage.org/data/gdal_sample_v1.2_spi_nonlinear_webp_elevation.gpkg

Possibly affecting also other datasources.

The error message is in the attached images as is not possible to copy it from DB Manager message bar, the QGIS log shows an empty message.

Screenshot_20170913_153018.png (43.2 KB) Giovanni Manghi, 2017-09-14 01:05 PM

History

#1 Updated by Alessandro Pasotti about 3 years ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti about 3 years ago

  • Status changed from Open to Feedback

Cannot reproduce on master on Linux.

#3 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Feedback to Open

Alessandro Pasotti wrote:

Cannot reproduce on master on Linux.

Hi Alessandro, I can only test on Windows this days. I just updated to 01468d0879 and still see it. Maybe this revision has not all the latest fixes?

#4 Updated by Alessandro Pasotti about 3 years ago

If that's only on windows that's expected: gpkg raster support in GDAL 2.2.1 is broken on windows: you'll need at least GDAL 2.2.2RC1

#5 Updated by Giovanni Manghi about 3 years ago

ok so maybe this can be closed already.

#6 Updated by Alessandro Pasotti about 3 years ago

I'd leave this open until you are able to confirm that the new GDAL actually fixes it.

#7 Updated by Giovanni Manghi about 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

GDAL updated and fix is confirmed.

Also available in: Atom PDF