Bug report #17109

Adding WFS layer fails with "unexpected end of file"

Added by Fedor Baart almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:2.18.2 Regression?:No
Operating System:OSX 10.11.6 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:25008

Description

I am trying to add the following WFS layer "https://waterwebservices.rijkswaterstaat.nl/services/distributielaagWFS/distributielaag_dbo" to a QGIS map. I use the following steps:

Steps:
-> layer -> add layer -> wfs layer
Enter url of service above.
Click Connect

Result:
Popup with message: unexpected end of file.

Expected result:
Loaded map.

I have manually tried to run a getcapabilities request and I do get a proper response (with an eof at the end).
I have also downloaded the data using the ogr2ogr tool. This works fine. Also the ogrinfo gives proper metadata.
I have tried different WFS versions.

Can you confirm that this is a bug in QGIS?

Details
QGIS version 2.18.2
Platform OSX 10.11.6
GDAL 2.1.2

Kind regards,

Fedor Baart

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

Just tested on 2.18.12 on Linux, no error message and if you force the service to 1.0 the layers are loaded (but the server is very slow).

#2 Updated by Giovanni Manghi almost 3 years ago

Closing for lack of feedback, please reopen if necessary.

#3 Updated by Even Rouault over 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF