Bug report #17036

python error when using the "create grid" tool and outputting to postgis

Added by Giovanni Manghi over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24935

Description

Traceback (most recent call last): File "/usr/share/qgis/python/plugins/processing/algs/qgis/GridPolygon.py", line 152, in processAlgorithm sink, width, height, originX, originY, hSpacing, vSpacing, hOverlay, vOverlay, feedback) File "/usr/share/qgis/python/plugins/processing/algs/qgis/GridPolygon.py", line 195, in _rectangleGrid sink.addFeature(ft, QgsFeatureSink.FastInsert) AttributeError: 'NoneType' object has no attribute 'addFeature'

seen on master/ubuntu 16.04

is ok if outputting to temp layer or shapefile.

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

Can't reproduce on master. Is this still an issue?

#2 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF