Bug report #17027

[Composer] "Follow map theme" option slow down composer ui when used with complex projects

Added by Dominique Lyszczarz about 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24926

Description

I often encounter performance drop down of the composer interface when enabled "Follow map theme" option with relatively complex projects, for example about 20 layers (some of them with multiple styles) and a few map themes. Selecting, moving or editing item of the composer become completly unresponsive, disable the option brings everything back to normal.

Associated revisions

Revision f5876eab
Added by Nyall Dawson over 2 years ago

[layouts] Don't needlessly calculate layer sets for maps linked
to a map theme

This is very expensive to do, so avoid calculating it as much
as possible

Refs #17027

Revision 0e08e329
Added by Nyall Dawson over 2 years ago

[layout] Cache map item theme preset lookups

Since theme style override lookups are expensive, cache them
to avoid unnecessary duplicate calls

Fixes #17027

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

Is this just in master or also 2.18?

#2 Updated by Dominique Lyszczarz about 3 years ago

Only in master

#3 Updated by Giovanni Manghi about 3 years ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes
  • Status changed from Feedback to Open

#4 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF