Bug report #17017

QgsDataSourceURI missing from qgis.core

Added by Axel H├Ârteborn almost 3 years ago. Updated over 2 years ago.

Status:Rejected
Priority:Normal
Assignee:Denis Rouzaud
Category:Python bindings / sipify
Affected QGIS version:master Regression?:No
Operating System:Windows x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24916

Description

Really odd bugg I cant import QgsDataSourceURI from qgis.core

if I run dir(qgis.core) in the python console I find QgsDataSourceURI among the classes.
When I try import qgis.core.QgsDataSourceURI
I get: AttributeError: module 'qgis.core' has no attribute 'QgsDataSourceURI'

History

#1 Updated by Denis Rouzaud over 2 years ago

  • Status changed from Open to Feedback

can you try from qgis.core import QgsDataSourceURI
this works for me

#2 Updated by Alexander Bruy over 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Rejected

In master this class was renamed to QgsDataSourceUri

Also available in: Atom PDF