Bug report #16947

GDalUtils.getFormatShortNameFromFilename returrn 'Gtiff' for ESRI

Added by pg Taknok almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GDAL
Affected QGIS version:2.18.9 Regression?:No
Operating System:OSX Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:24846

Description

One user of my plugin reported me that for some files extensions the color of image in output changed. I'm using processing with gdal clip by extend (link).
After investigation it appears that getFormatShortNameFromFilename return 'GTiff' when it should be 'EHdr' with a file.bil. This is due to getSupportedRasters where the if DMD_EXTENSION in metadata return false. I was wondering why DMD_EXTENSION isn't in the wrapper meta, because when I run the command in a shell (gdalwarp -of EHdr ...) it's perfectly working.

Is that normal ? Should it be fixed ?

History

#1 Updated by Alexander Bruy almost 3 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

This is not a Processing or QGIS issue. Submit pull-request to GDAL with correct DMD_EXTENSION metadata

Also available in: Atom PDF