Bug report #16944

'selection' parameter in QGIS processing not working

Added by R. R. almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:Yes Copied to github as #:24843

Description

The selection parameter does not work here on QGIS 2.99 master.

selection_01.png (27 KB) R. R., 2017-07-29 06:46 PM

History

#1 Updated by R. R. almost 3 years ago

#2 Updated by Giovanni Manghi almost 3 years ago

  • Regression? changed from No to Yes
  • Crashes QGIS or corrupts data changed from No to Yes
  • Priority changed from Normal to High

#3 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

That's because you're using 2.x API. In 3.0 this should be "enum" instead of "selection"

#4 Updated by R. R. almost 3 years ago

Thx for the info. Where can I find the new parameter types? I noticed that 'multiple field' is also available, but it lists layers instead of fields (see #16348).

Also available in: Atom PDF