Bug report #16875

Switching from attribute table to forms view: selected items should be displayed in form

Added by Andreas Neumann almost 3 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Matthias Kuhn
Category:Forms
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24774

Description

If one selects a single feature in the attribute table (the table row is blue and the window top bar says "selected: 1") and switches to form view, the selected item is not active in the form view.

If just one feature is selected, the switch from attribute table to form should definitely show this one selected feature as active.

In addition, the side bar should scroll, so that the selected feature is visible in the side bar.


Related issues

Related to QGIS Application - Bug report #16196: attribute table - open in show selected features/form vie... Closed 2017-02-15

History

#1 Updated by Andreas Neumann almost 3 years ago

Issue #16196 is similar (or even the same)

#2 Updated by Jürgen Fischer almost 3 years ago

  • Related to Bug report #16196: attribute table - open in show selected features/form view doesn't display selected feature added

#3 Updated by Andreas Neumann over 2 years ago

  • Assignee set to Matthias Kuhn

#4 Updated by Andreas Neumann over 2 years ago

  • Subject changed from Switching from attribute table to view: selected items should be displayed in form to Switching from attribute table to forms view: selected items should be displayed in form

#5 Updated by Andreas Neumann almost 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Already implemented in current master (3.4). Can't find the corresponding github commit - but it is implemented ;-)

Also available in: Atom PDF