Bug report #16852

layer actions triggered from identify + right click do not have variables populated (@click_x and others )

Added by Regis Haubourg about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Regis Haubourg
Category:Actions
Affected QGIS version:2.18.11 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24751

Description

Hi,
I discovered this regression in 2.18.10.

How to reproduce:

- add the default actions to a layer
- identify + right clic on the layer
- execute the "display clic coordinate" action
-> coordinates displayed are empty

Here this breaks production applications.

PS: in qgis 3.0, the actions list on right clic of identify has totally disappeared. Is that on purpose ?

Associated revisions

Revision c9c1c349
Added by Paul Blottiere almost 3 years ago

Fixes #16852 by adding click_x and click_y variables to resolve actions

Revision bd30e12c
Added by Paul Blottiere almost 3 years ago

Merge pull request #5597 from pblottiere/bugfix-clickxy

[bugfix] Fixes #16852 by adding click_x and click_y variables to resolve actions

Revision c9692959
Added by Paul Blottiere almost 3 years ago

Fixes #16852 by adding click_x and click_y variables to resolve actions

Revision 10b34b90
Added by Paul Blottiere almost 3 years ago

Merge pull request #5660 from pblottiere/bugfix-clickxy-218

[backport][bugfix] Fixes #16852 by adding click_x and click_y variables to resolve actions

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

Hi Regis, this worked in 2.18.9? If yes then regression within the 2.18 release are really start to pile up... being the 2.18.10 a release with many of them...

#2 Updated by Regis Haubourg about 3 years ago

  • Assignee set to Regis Haubourg
  • Status changed from Feedback to Open

I have been trying to find any commit related for one hour and didn't anything clear recently (since october!)
It is a regression for sure, but git bisect with QGIS compile time is not an option. Better go to a fix and a unit test quickly.
I think I'll have some funds for fixing that. I take the action .

#3 Updated by Giovanni Manghi about 3 years ago

  • Affected QGIS version changed from 2.18.10 to 2.18.11

#4 Updated by C M about 3 years ago

Proposed Pull Request (for v2.18): https://github.com/qgis/QGIS/pull/5068

#6 Updated by Paul Blottiere almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF