Bug report #16849

focusing on label item in composer high CPU and properties dock size changing constantly

Added by Regis Haubourg almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:24748

Description

Hi, strange issue, just create a simple item with text in a composer,
and its "item" properties dialog width keep getting larger, and CPU consumption raising.
Unfocusing stops this, refocusing triggers it again.
see video here: https://youtu.be/tJJ7FpoETsU

Associated revisions

Revision 082dafe2
Added by Nyall Dawson almost 3 years ago

Fix infinitely growing widgets

Fixes #16849

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Open to Feedback

Hi Regis, if is not a regression or does not causes a crash or data corruption we should tag this with "normal" priority. Agree?

#2 Updated by Regis Haubourg almost 3 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

Well, I could have flagged a crash yes, because I think the infinite loop will end this way if you wait long enough :)

#3 Updated by Nyall Dawson almost 3 years ago

Regis -
possible suspects here are eb8f91a55677b2e9118210871ab27ca847364ec2, 0802586a13e5f21238daf223d5d5d754bce23c7f and 0b9fb5d6e199e4a52820b4d74a392196f459cad5

Can you checkout the commits just before each of these and see if you can narrow this issue down to one of those?

#4 Updated by Giovanni Manghi almost 3 years ago

Hi Regis! were you able to test Nyall suggestion?

#5 Updated by Nyall Dawson almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

Also available in: Atom PDF