Bug report #16824

regression: identify tool's highlight (red point/line/polygon) mislocated when panning/zooming around

Added by Mathieu Pellerin - nIRV almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Tools
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24723

Description

The attached screencast is self-explanatory.

Steps to reproduce
  1. Create a new project
  2. Add a polygon layer to your project
  3. Select the identify tool, and click on a polygon
  4. Pan the map around a bit (using the mouse wheel), you'll notice the selected feature's highlight polygon (red) doesn't get drawn at the right location

identify-highlight-broken.mp4 (1.92 MB) Mathieu Pellerin - nIRV, 2017-07-10 08:23 AM

Associated revisions

Revision 51170aec
Added by Mathieu Pellerin - nIRV almost 3 years ago

Revert "highlight fix" due to regression (fixes #16824)

This reverts commit 46596914e11dae13cd4d986941246c12f30aa0d9.

History

#2 Updated by Andreas Neumann almost 3 years ago

Confirmed. Same happens on my QGIS master build 502efd1

#3 Updated by Mathieu Pellerin - nIRV almost 3 years ago

The regression was caused by this 46596914e11dae13cd4d986941246c12f30aa0d9

Reverting it fixes the wrongly positioned highlight.

#4 Updated by Radim Blazek almost 3 years ago

The fix resolved this problem:
1. highlight a feature programmatically when it is outside current map canvas extent
2. zoom to that feature
3. the highlight disappears

Please don't simply revert without fixing the original problem.
More info http://lists.osgeo.org/pipermail/qgis-developer/2017-June/048948.html

#5 Updated by Mathieu Pellerin - nIRV almost 3 years ago

Radim, no worries, I didn't commit a revert, I actually reached out to you via github to point out the regression. Happy to test out any commit from you that'd fix the regression.

#6 Updated by Mathieu Pellerin - nIRV almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF