Bug report #16819

Saving point vector as CSV in 2.18.10 X/Y values are not exported anymore

Added by magerlin - over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:2.18.11 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24718

Description

Saving a shape file as cvs (by rightclicking in the layers panel) used in earlier versions to automatically add an x and y attribute to the csv file. This does not happen anymore even though geometry AS_XY is the default under Layer Options in the "Save vector layer as..." dialogue.

If one chooses geometry AS_XYZ instead the columns are added to the csv file as expected.

Associated revisions

Revision fc7ac832
Added by Jürgen Fischer over 2 years ago

vector file writer: reapply integer options (accidentally removed in 9a6235db; fixes #16811, #16819)

Revision cb088a2a
Added by Jürgen Fischer over 2 years ago

vector layer save as: adjust our to OGR's defaults
  • GPX_USE_EXTENSIONS default is false not true (fixes #16811)
  • CSV GEOMETRY is none not AS_XY (fixes #16819)

(followup 9a6235db)

Revision 601e3735
Added by Jürgen Fischer over 2 years ago

vector layer save as: adjust our to OGR's defaults
  • GPX_USE_EXTENSIONS default is false not true (fixes #16811)
  • CSV GEOMETRY is none not AS_XY (fixes #16819)

(backported from commit cb088a2a0cb6224600504574f749348cc4df8bf2)

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Subject changed from Save as CSV in 2.18.10 stores no geometry to Saving point vector as CSV in 2.18.10 X/Y values are not exported anymore
  • Regression? changed from No to Yes
  • Category changed from Data Provider/Delimited Text to Vectors
  • Priority changed from Normal to High
  • Operating System deleted (Win 7, 64 bit)

Confirmed.

#2 Updated by Jürgen Fischer over 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#3 Updated by salvatore fiandaca over 2 years ago

In 2.18.11 the problem is still there

#4 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Closed to Open

Jurgen, seems the fix was not backported to 2.18, correct?

#5 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.18.10 to 2.18.11

#6 Updated by Jürgen Fischer over 2 years ago

  • Status changed from Open to Closed

#7 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF