Bug report #16806

Non valid VRT logic due to GDAL changes in QgsGdalDataItems

Added by Richard Duivenvoorde about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Even Rouault
Category:Data Provider
Affected QGIS version:2.18.0 Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24705

Description

See this thread:
https://lists.osgeo.org/pipermail/qgis-developer/2017-July/049234.html

According to Even the logic here:
https://github.com/qgis/QGIS/blob/master/src/providers/gdal/qgsgdaldataitems.cpp#L246
isn't working anymore for GDAL2:

Quote: " Actually L246 shows a particular case for VRT. But I think this logic is now invalid since GDAL 2.0, since
GDALIdentifyDriver() will now retun "VRT" for a raster VRT, and "OGR_VRT" for a vector VRT (in GDAL 1.X era GDALIdentifyDriver() only worked on raster drivers)"

So probably this code should be updated.

Associated revisions

Revision 49071808
Added by Even Rouault almost 3 years ago

[Browser] Fix invalid detection of OGR VRT by GDAL provider, and fix broken detection of OGR VRT (fixes #16806)

Revision 2e87d32f
Added by Even Rouault almost 3 years ago

[Browser] With GDAL 2.x, fix invalid detection of OGR VRT by GDAL provider, and fix broken detection of OGR VRT (fixes #16806)

History

#1 Updated by Even Rouault almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#2 Updated by Even Rouault almost 3 years ago

  • Resolution set to fixed/implemented
  • Affected QGIS version changed from master to 2.18.0
  • Assignee set to Even Rouault

Also available in: Atom PDF