Bug report #16767

Processing: "Run as batch process..." button not shown entirely

Added by Harrissou Santanna about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24666

Description

Compared to QGIS 2.18, it looks like the header of the tabs in Processing dialog is thinner, hence the "Run as batch process..." button label is not correctly rendered.
master 0f83a5f

run_batch.PNG (13.5 KB) Harrissou Santanna, 2017-06-29 04:41 PM

run_batch_withFusion.PNG (18.3 KB) Harrissou Santanna, 2017-06-29 05:08 PM

Associated revisions

Revision a95cbe9d
Added by Nyall Dawson almost 3 years ago

Move 'Run as batch' button to bottom of algorithm dialog

Inserting it into the tab widget doesn't work well cross
platform/between hidpi/lowdpi displays. So instead add
it as a normal button in the button box.

Also fix capitalization of button text

Fixes #16767

History

#1 Updated by Harrissou Santanna about 3 years ago

It looks like using another Application style (settings --> Options --> General), namely Fusion (instead of WindowsXp or WindowsVista) gives a better result but still all the button frame is not shown (trimmed on top).

#2 Updated by Nyall Dawson almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF