Bug report #16725

Parser error in Atlas 'Output filename expression' textbox - badly handled error

Added by Steve Lowman almost 3 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.14.15 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:24624

Description

When manually entering the 'Output filename expression', if you leave the textbox before the expression is fully parsable, you get an error message box (see image attached). The problem is that when you click 'OK', instead of returning you to the textbox to correct the expression, you just get the message box again, for ever. The only way out I could find is to kill the whole application, so effectively I think QGIS is crashed by this.

(I gave this Category of 'Map Composer/Printing', but maybe should be 'Expressions'?)

Repeating message box.png (16.7 KB) Steve Lowman, 2017-06-19 06:16 PM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#2 Updated by Hugo Mercier over 1 year ago

Not reproduced with QGIS 3.3 where the message box is replaced by a message bar

#3 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

#4 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#5 Updated by Alexander Bruy over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF