Bug report #16668

pgpass do not work on qgis master

Added by Andy Harney over 2 years ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24567

Description

Hi,

On QGIS master, QGIS will fail to retrieve passwords from a pgpass.conf file.
This happens when expanding a db tree in Database > DB Manager
The database is added in the PostGIS data provider without a password, which can connect and load layers.

Attached is a screenshot showing this.

Many Thanks.

PGPASS.png (7.17 KB) Andy Harney, 2017-06-06 11:37 AM

PGPASS_Master.png (18.6 KB) Andy Harney, 2017-06-06 02:09 PM

PGPASS_2.18.9.png (21 KB) Andy Harney, 2017-06-06 02:10 PM


Related issues

Related to QGIS Application - Bug report #10932: qgis not parsing pg_service.conf properly Closed 2014-07-23

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High
  • Subject changed from pgpass - Windows to pgpass do not work on qgis master

#2 Updated by Sandro Santilli over 2 years ago

It could make a good case to add to the new DBManager testsuite: https://github.com/qgis/QGIS/pull/4688
Can you tell which version was last found working ? Was 2.18 branch tested too ?

#3 Updated by Andy Harney over 2 years ago

Sandro Santilli wrote:

It could make a good case to add to the new DBManager testsuite: https://github.com/qgis/QGIS/pull/4688
Can you tell which version was last found working ? Was 2.18 branch tested too ?

I've just tested 2.18.9. Setting up a PostGIS connection fails, as does using DB Manager.
On master, setting up a PostGIS connection works, but DB Manager fails.
I've added more images to show.
Thanks.

#4 Updated by Sandro Santilli over 2 years ago

Giovanni as you marked this as a regression, do you know which older version worked fine ?

#5 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from High to Normal
  • Regression? changed from Yes to No

Sandro Santilli wrote:

Giovanni as you marked this as a regression, do you know which older version worked fine ?

I overlooked the notification and assume that was something only affecting master.

#6 Updated by Jürgen Fischer over 2 years ago

Probably a duplicate of #10932 (unix style line endings (linefeed only) expected)

#7 Updated by Jürgen Fischer over 2 years ago

#8 Updated by Giovanni Manghi 11 months ago

  • Status changed from Open to Feedback

Please check if this issue is still valid on QGIS 3.4.5 or 3.6.

#9 Updated by Andy Harney 11 months ago

Giovanni Manghi wrote:

Please check if this issue is still valid on QGIS 3.4.5 or 3.6.

Just tested on QGIS 3.6, Windows 10. This issue is resolved.

#10 Updated by Giovanni Manghi 11 months ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF