Bug report #16616

Select feature using an expression is missing the Fields and Values from loaded PostGIS spatial layer

Added by David Mancini over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Expressions
Affected QGIS version:2.18.8 Regression?:Yes
Operating System:Windows 7 Professional Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24516

Description

I have been using QGIS 2.18.6 for the past few month or so and today I decided to try updating to QGIS 2.18.8. In 2.18.8 when I load a PostGIS spatial layer and then click "Select feature using an expression", then click on the + next to "Fields and Values" the only option listed is NULL. I have just reverted back to the previous 2.18.6 version and the Fields and Values is populated with the database table column names.

Here's some more info behind the scenes from our PostgreSQL/PostGIS database server
SELECT version(), PostGIS_full_version();

PostgreSQL 9.4.5 on x86_64-unknown-linux-gnu, compiled by gcc (Debian 4.9.2-10) 4.9.2, 64-bit
POSTGIS="2.1.4 r12966" GEOS="3.4.2-CAPI-1.8.2 r3921" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.10.1, released 2013/08/26" LIBXML="2.9.1" LIBJSON="UNKNOWN" TOPOLOGY RASTER

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to fixed/implemented
  • Regression? changed from No to Yes
  • Status changed from Open to Closed

This has been already fixed and you just need to wait a new build or install the "nightly" for 2.18.

Also available in: Atom PDF