Bug report #16607

error when editing data on 2.18.8 and postgresql 9.4

Added by Konradin Fischer over 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:2.18.8 Regression?:No
Operating System:win7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24507

Description

we worked with postgres 9.4 and qgis 2.18.7. after updating to 2.18.8 we get an error when we try to modify data.
"Layer vw_qgep_reach: PostGIS error while adding features: FEHLER: Wert zu lang für Typ character varying(16)"

data-demodata.zip (4.65 MB) Konradin Fischer, 2017-05-26 09:44 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Crashes QGIS or corrupts data changed from Yes to No
  • Subject changed from update 2.18.7 to 2.18.8; postgis connection to error when editing data on 2.18.8 and postgresql 9.4
  • Status changed from Open to Feedback

I cannot confirm it but I'm not on pgsql 9.4

postgis version? can you attach a sample/dump of the data?

#2 Updated by Konradin Fischer over 3 years ago

we use postgis 2.3.0
sorry, the database is confidential, it's a newer then the attached

#3 Updated by Jürgen Fischer over 3 years ago

Is that the same as the demo dataset

#4 Updated by Giovanni Manghi over 3 years ago

  • Assignee deleted (Jürgen Fischer)

I installed on a Windows7 VM postgresql 9.4 and postgis 2.3, restored the QGEP sample database (as explained on their site), added to qgis 2.18.8 the layer vw_qgep_reach, tried to edit it, no errors.

If the workflow to get the error is different please specify here the * exact and precise* list of steps on how to replicate. Thanks.

#5 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF