Bug report #16595

No "Recently used expressions" in expression editor

Added by Saber Razmjooei over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Expressions
Affected QGIS version:2.18.8 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24497

Description

The option to show previously used expressions have been removed from 2.18.8


Related issues

Related to QGIS Application - Bug report #16589: No fields display in expression editor under Fields an va... Closed 2017-05-21

Associated revisions

Revision 20dde725
Added by Nyall Dawson over 4 years ago

Followup 2185d42, fix missing field names in expression builder

(fixes #16589, #16595)

cherry-picked from 9a19a5f

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback
  • Affected QGIS version changed from 2.18.7 to 2.18.8
  • Regression? changed from No to Yes

Hi Saber,

if confirmed is a regression, but i just tested on Linux and Windows and I can see that group in both

"Recent (fieldcalc)"

#2 Updated by Giovanni Manghi over 4 years ago

eventually not duplicate of #16589 ?

#3 Updated by Harrissou Santanna over 4 years ago

Giovanni, it appears in Field Calculator (also does the "fields and values" group) but not in the "Select by expression" dialog (tested on Windows 10)

#4 Updated by Giovanni Manghi over 4 years ago

Harrissou Santanna wrote:

Giovanni, it appears in Field Calculator (also does the "fields and values" group) but not in the "Select by expression" dialog (tested on Windows 10)

oh... right...

#5 Updated by Nyall Dawson over 4 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

#6 Updated by Jürgen Fischer over 4 years ago

  • Duplicates Bug report #16589: No fields display in expression editor under Fields an values (QGIS 2.18.8) added

#7 Updated by Jürgen Fischer over 4 years ago

  • Duplicates deleted (Bug report #16589: No fields display in expression editor under Fields an values (QGIS 2.18.8))

#8 Updated by Jürgen Fischer over 4 years ago

  • Related to Bug report #16589: No fields display in expression editor under Fields an values (QGIS 2.18.8) added

Also available in: Atom PDF