Bug report #16551

Zoom to layer doesn't work

Added by David BAUJON over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:2.18.7 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24457

Description

Hello,

I have a .qgs with a shp (2 points in my shp).

I edit the shp with a new point.

I close the .qgs without recording.

I open the .qgs.

I zoom on layer. The extent is always the extent recording at the beginning in the project (on my 2 points)

Try, it's the same thing on all computer

Thanks,

test.zip (6.64 KB) David BAUJON, 2017-05-15 06:36 PM

Screen Shot 2017-05-21 at 12.53.30 AM.png - Duplicated layer (158 KB) Eron Lloyd, 2017-05-21 06:55 AM

Screen Shot 2017-05-21 at 12.53.17 AM.png - Original layer (155 KB) Eron Lloyd, 2017-05-21 06:55 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Category changed from Processing/QGIS to Map Canvas
  • Priority changed from High to Normal
  • Regression? changed from Yes to No
  • Status changed from Open to Feedback
  • Assignee deleted (Victor Olaya)

Please attach project and sample data, thanks.

#2 Updated by David BAUJON over 3 years ago

#3 Updated by Giovanni Manghi over 3 years ago

where is the issue?
if the project is saved to a certain extent then it won't change (if now re saved) even if the extent of the layers is bigger (or get bigger).

#4 Updated by David BAUJON over 3 years ago

Hello,

I'm OK with u.

The issue is : when you open my project "test.qgs", the extent show 2 points. So, I zoom to layer "test" and nothing happens.
It should change the extended and show my 3 points

My last version of QGIS was the 2.6. It work.

#5 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Open
  • Operating System deleted (Windows 8.1)
  • Affected QGIS version changed from 2.14.13 to 2.18.7
  • Subject changed from Zoom to layer don't work after editing layer in a .qgs project - QGIS 2.14.13 to Zoom to layer don't work

I see, there is also no need to edit the layer. The "zoom to layer" function to not work in your provided point layer/project.

#6 Updated by Eron Lloyd over 3 years ago

I can confirm this as well for 2.18.7 on OS X, official build. I have a GeoPackage with a point layer that has five features, but only will zoom to the first three. However, when I duplicate the layer and zoom to that layer, it behaves as expected. I've attached screenshots, with the duplicated points offset to compare.

#7 Updated by Giovanni Manghi over 3 years ago

Eron Lloyd wrote:

I can confirm this as well for 2.18.7 on OS X, official build. I have a GeoPackage with a point layer that has five features, but only will zoom to the first three. However, when I duplicate the layer and zoom to that layer, it behaves as expected. I've attached screenshots, with the duplicated points offset to compare.

please provide sample data.

#8 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Open to Feedback

#9 Updated by Jürgen Fischer over 3 years ago

  • Subject changed from Zoom to layer don't work to Zoom to layer doesn't work

#10 Updated by Giovanni Manghi about 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF