Bug report #16508

Opening Large Shape or oracle table (table) takes more time then before

Added by A. Egberts over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Attribute table
Affected QGIS version:2.18.7 Regression?:Yes
Operating System:windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:24414

Description

When I am opening a lagre (500mb) shape, or Oracle connection, it take a lot of time before I can see the counter, getting the rows of the table.

in the older version you get this rigt away, end you could cancel it rigth away.

now it looks like it loads the whole table?


Related issues

Related to QGIS Application - Bug report #16239: master: (much) slower rendering (and attribute table open... Closed 2017-02-27

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback
  • Regression? changed from No to Yes
  • Priority changed from Low to High
  • Assignee deleted (A. Egberts)

When you day "older version", do you mean 2.14 or a previous 2.18.* release?

can you share your dataset? if not can you see the same with a large dataset from OSM like http://download.geofabrik.de/europe/netherlands-latest-free.shp.zip ?

#2 Updated by Giovanni Manghi over 4 years ago

this report seems in line with #16239

#3 Updated by Jürgen Fischer over 4 years ago

  • Related to Bug report #16239: master: (much) slower rendering (and attribute table opening) time compared to 2.18.4 added

#4 Updated by Nyall Dawson over 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Duplicate of #16239

Also available in: Atom PDF