Bug report #16492

Attribute table: crash removing features when cell is in editing mode

Added by Luigi Pirelli over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Attribute table
Affected QGIS version:2.18.7 Regression?:Yes
Operating System:Any Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:24398

Description

confirmed in 2.18/3.X. follow these steps to replicate:

1) create a layer (tested with shape and mapinfo) with a column attribute.
2) add some features and save. You can also edn editing and close attribute table
3) open attribute table
4) start editing
5) with shift pressed => select all features => latest feature cell is opened in editing
5) click on "delete features" action button => crash!

issue_15976_rows_switch_adding_attributes.zip (3.56 KB) Giovanni Manghi, 2017-05-01 11:35 AM

Associated revisions

Revision db89929a
Added by Alessandro Pasotti over 4 years ago

[bugfix] Attribute table crashes QGIS when deleting selected

Fixes https://issues.qgis.org/issues/16492

Needs-backporting

Revision 4f82b0ba
Added by Alessandro Pasotti over 4 years ago

[bugfix] Attribute table crashes QGIS when deleting selected

Fixes https://issues.qgis.org/issues/16492

Backport from https://github.com/qgis/QGIS/pull/4535

History

#1 Updated by Giovanni Manghi over 4 years ago

It happens with certain datasets like the one attached, but not all.

#2 Updated by Luigi Pirelli over 4 years ago

crash does not happen if the latest cell is not in editing mode

#3 Updated by Luigi Pirelli over 4 years ago

  • Assignee set to Alessandro Pasotti

assigned to APasotti because he's already working on other attribute table issues

#4 Updated by Luigi Pirelli over 4 years ago

  • Assignee deleted (Alessandro Pasotti)

#5 Updated by Alessandro Pasotti over 4 years ago

  • Assignee set to Alessandro Pasotti

#6 Updated by Alessandro Pasotti over 4 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Resolution set to fixed/implemented

#7 Updated by Alessandro Pasotti over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF