Bug report #16484

Rendering issue using @geometry_point_num for styling Z values of vertices

Added by Regis Haubourg almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:ALL Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24392

Description

I attempt to render Z values on 3D lines and polygons following my work here http://osgeo-org.1560.x6.nabble.com/Z-or-M-styling-in-QGIS-td5301770.html#a5301817, I found a rendering issue.

A video here https://www.youtube.com/edit?video_id=NdoyysCzEUs shows the issue.

I narrowed down the expression that seem to be triggering the error. It's on a marker line renderer, using a geometry generator to materialize the Z value as a vertical line with length in map units.

z(point_n($geometry,@geometry_point_num))

In my guess @geometry_point_num seems to be affected by current map extent.

qgs and gpkg files to reproduce are joined to the ticket.

sample_zm_data.gpkg (57 KB) Regis Haubourg, 2017-04-29 01:42 AM

style_z.qgs (63.2 KB) Regis Haubourg, 2017-04-29 01:42 AM

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

You can disable the automatic clipping of geometries to map extent in the advanced menu for the layer's symbology.

Also available in: Atom PDF