Bug report #16455

Refreshing provider alg list does not refresh toolbox

Added by Victor Olaya over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Processing/Core
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24364

Description

When models or scripts are added/deleted/edited, the provider is refreshed, but the toolbox doesnt change at all

After a bit of manual testing, looks like callig something like this

QgsApplication.processingRegistry().providerById('model').refreshAlgorithms()

does not trigger the updateProvider() method of the toolbox. It should be connected to the algorithmsLoaded() signal, but maybe it's a different instance of the provider...

Associated revisions

Revision b34ee28c
Added by Nyall Dawson over 2 years ago

[processing] Fix refreshing alg list does not refresh toolbox

Fix #16455, #16463

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#2 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#3 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#4 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF