Bug report #16435

Expression history combo box in 'Select by expression' dialog

Added by Simon Gröchenig over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Tools
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24344

Description

As I often use same/similar expressions in the 'Select by expression' dialog, I miss a combo box with previous expressions.

recent_selection.png (56.3 KB) Nino Formica, 2018-03-08 01:18 PM

History

#1 Updated by Simon Gröchenig over 2 years ago

By selecting one of the previous expressions, it can be inserted into the text field.

#2 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Nino Formica over 1 year ago

I think this is not a bug but a feature request.
Anyway in "Select by expression" (QGIS 2.18.17) it's already there a "Recent selection" item (look at attachment): I believe this is enough !?

#4 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Nino Formica wrote:

I think this is not a bug but a feature request. I believe this is enough !?

agree

#5 Updated by Simon Gröchenig over 1 year ago

The "Recent Selection" item is good enough!

Issue can be closed

#6 Updated by Nyall Dawson over 1 year ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF