Bug report #1642

v.to.db GRASS tool interface problem

Added by mvizzari - over 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Lorenzo Masini
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11702

Description

the v.to.db GRASS tool interface of qGIS when activated doesn't find the key column and has not the parameter of the column to be updated.

Thanks a lot for your work!!

History

#1 Updated by Paolo Cavallini about 11 years ago

It does show the column list, but it does not update it if the module is already opened when a layer is loaded. To check, close the module, load a layer and see if you can see the list of columns.
However, I found another problem: the module does not work if you want to update several columns, as it happens for X.Y coordinates (this option requires two columns, but the module can only add one):

v.to.db [email protected] layer=1 option=coor units=meters columns=Z_MEAN

´┐╝This option requires at least two columns

#2 Updated by Lorenzo Masini about 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed the attribute table update issue in 4fe683b3 (SVN r11344).

For the multiple input issue, open an other ticket.

#3 Updated by Giovanni Manghi about 11 years ago

Replying to [comment:3 rugginoso]:

For the multiple input issue, open an other ticket.

done

http://trac.osgeo.org/qgis/ticket/1867

#4 Updated by Paolo Cavallini almost 11 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

#5 Updated by Paolo Cavallini almost 11 years ago

  • Status changed from Feedback to Open

#6 Updated by Paolo Cavallini almost 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF