Bug report #16397

"hidden" edit widget does not work on QGIS 2.18 (and master)

Added by Giovanni Manghi over 2 years ago. Updated over 2 years ago.

Status:Rejected
Priority:High
Assignee:Matthias Kuhn
Category:Edit widget
Affected QGIS version:2.18.7 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24306

Description

subject says it all. Works fine on 2.14.13

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#2 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#3 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#4 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.18.4 to 2.18.7
  • Subject changed from "hidden" edit widget does not work on QGIS 2.18.5 (and master) to "hidden" edit widget does not work on QGIS 2.18 (and master)

#5 Updated by Alessandro Pasotti over 2 years ago

  • Assignee set to Alessandro Pasotti

#6 Updated by Matthias Kuhn over 2 years ago

  • Assignee changed from Alessandro Pasotti to Matthias Kuhn

#7 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Rejected
  • Resolution set to invalid

There was a change by design: the widget now only works in attributes forms. To hide a column in the table of attributes is necessary to right click the header and choose "hide".

Also available in: Atom PDF