Bug report #16392

regression: composer legend items don't restore properly on project load

Added by Mathieu Pellerin - nIRV over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24301

Description

Under QGIS master, composer legend items don't restore properly on project load. The composer item's layers appear not to link to project layers, resulting in missing symbols.

Steps to reproduce
  1. Launch QGIS master, and create a new project
  2. Add one preexisting vector layer dataset onto the new project
  3. Create a new composer
  4. Add a map item as well as a legend item
  5. Click on the legend item and open its properties panel
  6. Uncheck [ ] auto update
  7. Save the project
  8. Restart QGIS, and reload the saved project
  9. Open the composer
  10. Notice the legend item is broken, with the one vector dataset missing its symbol

History

#1 Updated by Mathieu Pellerin - nIRV over 2 years ago

  • Assignee changed from Nyall Dawson to Matthias Kuhn

drum rolling git bisect spoke, the culbrid commit(s) is/are:

#f33aabd90aab071d8b1f8f163e6cbed8869110c3
#baa4c86262ab4276c75dcaa4a85cf48152bad732
#8cecf236df6910ae162be7c2c9af46d62647fd05
#1ffa9ee7a6e48e03e1c4876566f062b3b1e4b0b5

Matthias, those are all related to your layer order PR, pushed on March 23, 2017. I couldn't narrow it down to a single commit due to compilation error with commit f33aabd which was fixed in 1ffa9ee.

#2 Updated by Mathieu Pellerin - nIRV over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Confirmed as fixed in #da5c0ed2cd220dec0f55bbf036423c816bd5bddd .

Thanks Nyall.

Also available in: Atom PDF