Bug report #16386

QGIS and GDAL cannot be updated together on Ubuntu Xenial

Added by Scott Atkinson over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Low
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.4 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24295

Description

I'm proposing to update the priority of the original issue to Severe as it seems to break QGIS on Ubuntu 16.04, having to revert to 2.14 being the only means I've found to get a working version of QGIS. QGIS update fails on dependency gdal-abi-2-1-2, while that version of GDAL seems to have been pulled from the repos with the recent update to libgdal 2-1-3 + Dfsg.

Original Issue:
On Ubuntu Xenial, qgis and gdal can not be updated together.
Qgis 2.18.4 > qgis 2.18.5
Gdal 2.1.2 > gdal 2.1.3

Error messages:
Qgis:
Depends on: gdal-abi-2-1-2

libgdal 2.1.3. + Dfsg ~ xenial is available in the package sources!

Claas


Related issues

Related to QGIS Application - Bug report #16977: Cannot install 2.18/2.14 on Ubuntu Xenial with Ubuntugis ... Closed 2017-08-06

History

#1 Updated by Andre Joost over 2 years ago

This affects only the Ubuntugis version of QGIS. The Debian version of 2.18.5 runs fine on xenial (but with GDAL 1.11.3).

Maybe an issue with the ubuntugis packaging not in sync with the qgis.org/ubuntugis repo.

As a sidenote:

The Ubuntugis (stable) ppa provides GDAL 2.1.0 (with gdal-abi-2-1-0), and the Ubuntugis-unstable ppa provides GDAL 2.1.3 (with gdal-abi-2-1-3) for now.

QGIS should be able to work with both of them (but does neither currently).

#4 Updated by Scott Atkinson over 2 years ago

The workaround indicated by Andre of creating a fake gdal-abi-2-1-2 package (http://gis.stackexchange.com/questions/216780/cannot-install-qgis-2-18-from-repository-on-debian-stretch-package-gdal-abi-2/233830#233830) sorts the dependency problem out and allows the updates from the Ubuntugis repos for both GDAL and QGIS to function. Thanks Andre :)

#5 Updated by Scott Atkinson over 2 years ago

  • Status changed from Open to Closed

It's been fixed, the Ubuntugis repositories have been updated, and QGIS 2.18.5 installs and works fine now.

#6 Updated by Andre Joost about 2 years ago

Same issue, next round:

The ubuntugis unstable ppa has updated GDAL from version 2.1.3 to 2.2.1. Any previous QGIS installation gets removed on updating.

Installing QGIS 2.18.11 from http://qgis.org/ubuntugis xenial main is currently not possible, because it depends on GDAL 2.1.3.

Ubuntugis unstable has updated QGIS to 2.14.17, so at least that one works at the moment, if qgis org is disabled in the sources list, and sudo apt autoremove has been run.

I suggest to reopen this issue, and think of a better way to interact with ubuntugis updates.

#7 Updated by Giovanni Manghi about 2 years ago

  • Priority changed from Severe/Regression to Low
  • Description updated (diff)

Andre Joost wrote:

Same issue, next round:

The ubuntugis unstable ppa has updated GDAL from version 2.1.3 to 2.2.1. Any previous QGIS installation gets removed on updating.

Installing QGIS 2.18.11 from http://qgis.org/ubuntugis xenial main is currently not possible, because it depends on GDAL 2.1.3.

Ubuntugis unstable has updated QGIS to 2.14.17, so at least that one works at the moment, if qgis org is disabled in the sources list, and sudo apt autoremove has been run.

I suggest to reopen this issue, and think of a better way to interact with ubuntugis updates.

#16977 thanks for pointing the problem.

#8 Updated by Jürgen Fischer about 2 years ago

  • Related to Bug report #16977: Cannot install 2.18/2.14 on Ubuntu Xenial with Ubuntugis dependencies (and QGIS.org repos) added

#9 Updated by Richard Lang almost 2 years ago

And yet again. ubuntugis-unstable rolled their version of GDAL to 2.2.2 on 23rd Nov. #17615

#10 Updated by Alister Hood over 1 year ago

Is this currently an issue? If so I guess it should be reopened...

I have what looks like the same issue trying to install from http://qgis.org/ubuntugis-nightly, but maybe I have the wrong dependency repo enabled (I did sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable, but I'm not sure if that's right).

#11 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented

#12 Updated by Guillaume Chauvat over 1 year ago

While trying to update to the expected QGIS 3, I faced the same issue.
Since Debian repo isn't updated yet, I tried ubuntugis (https://qgis.org/ubuntugis/) and received:
"gdal-abi-2-2-2 not installable
libgdal20 (>= 1.8.0) not installable"

I guess the issue is not fixed yet.
(Linux Mint 18.2 / Xenial)

#13 Updated by Tim Beatty over 1 year ago

I have the same issue.

This was off a clean install of Ubuntu 16.04 / Xenial

#14 Updated by Giovanni Manghi over 1 year ago

Tim Beatty wrote:

I have the same issue.

This was off a clean install of Ubuntu 16.04 / Xenial

have you added the ubuntugis repository too?

Also available in: Atom PDF