Bug report #16359

In the print composer dynamically referencing to page size presets leads to wrong expression evaluation

Added by Johanna Seibert over 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:Low
Assignee:-
Category:Expressions
Affected QGIS version:2.18.4 Regression?:No
Operating System:Debian Jessie Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24269

Description

In the print composer a preset page size is set (e.g. A0). Item sizes/positions are defined using expression evaluation like "@layout_pagewidth -10". When changing the preset page size, it is expected that the item variable follows the change. However, the expression seems to be evaluated with the old layout presets. A work around is saving the project with the new page sizes and after reload the expression has been correctly evaluated.

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Feedback

Please retest using layouts engine on qgis 3.0 master

#3 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF