Bug report #16355

relative path in embedded groups are not respected

Added by Denis Rouzaud over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Martin Dobias
Category:Symbology
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24265

Description

Embeding a layer with SVG symbols defined as relative path in a project not defined at the same path as the embed project will show question marks (?) in place of the SVG symbol.

I suspect this is due to non forwarding relative path to the embed project path.

embedded_svg.zip (25.2 KB) Denis Rouzaud, 2017-03-15 12:25 AM

Associated revisions

Revision 3e18cc15
Added by Martin Dobias over 2 years ago

Respect relative paths in embedded projects (fixes #16355)

History

#1 Updated by Denis Rouzaud over 2 years ago

with a demo project, it's always better.

would it be possible to add a test for this too?

#2 Updated by Paolo Cavallini over 2 years ago

  • Subject changed from relative path in embed groups are not repsected to relative path in embed groups are not respcted

#3 Updated by Denis Rouzaud over 2 years ago

  • Subject changed from relative path in embed groups are not respcted to relative path in embedded groups are not respected

#4 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#5 Updated by Martin Dobias over 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented
  • Description updated (diff)

Also available in: Atom PDF