Bug report #16350

Spatial Bookmark Panel: precision gets trimmed

Added by Tobias Wendorff about 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Map Tools
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24260

Description

I believe this is a bug, since it simply makes no sense.

When creating a bookmark, it gets stored at high precision. Whenever you touch it, f.e. click into xMin, the precision gets limited to two digits. This might only be a GUI problem, since it's impossible to enter more than two digits at all.

Associated revisions

Revision 6c897b6b
Added by Alessandro Pasotti over 2 years ago

[bugfix] Bookmarks: fix a crash and show 6 digits

Fixes #17003 Spatial bookmarks keyboard navigation:
right-arrow causes a row to appear below the current
one and looks like a tree expansion (actually crashes
master)

Fixes #16350 Spatial Bookmark Panel: precision gets
trimmed

History

#1 Updated by Saber Razmjooei about 3 years ago

  • Category set to Map Tools
  • Operating System deleted (Microsoft Windows 7, 64-bit)
  • OS version deleted (6.1.7601)

#2 Updated by Giovanni Manghi almost 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Alessandro Pasotti over 2 years ago

  • Description updated (diff)
  • Assignee set to Alessandro Pasotti

#4 Updated by Alessandro Pasotti over 2 years ago

  • Status changed from Open to In Progress
  • Pull Request or Patch supplied changed from No to Yes

#5 Updated by Anonymous over 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF