Bug report #16334

Processing - Running a model freezes QGIS

Added by Magnus Nilsson over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:2.18.4 Regression?:No
Operating System:Windows 10 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:24244

Description

When I run a model with the green arrow to the right of the file path selected, QGIS freezes.

QGIS 2.18.4, 64 bit.

Roads.model (3.12 KB) Magnus Nilsson, 2017-03-11 03:30 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Target version deleted (Future Release - Lower Priority)
  • Status changed from Open to Feedback
  • Priority changed from Normal to High

Can you attach the model (and the data, or a sample)?

#2 Updated by Magnus Nilsson over 3 years ago

This seems to happen with any data or model that I use. I have tried several SHP files and models and QGIS still freezes. Try with the road network from http://download.geofabrik.de/europe/liechtenstein.html for example. I have attached a simple model.

#3 Updated by Alexander Bruy over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

Can't reproduce with latest point release 2.18.6. Please reopen if necessary and provide detailed steps to reproduce.

#4 Updated by Giovanni Manghi over 3 years ago

Magnus Nilsson wrote:

This seems to happen with any data or model that I use. I have tried several SHP files and models and QGIS still freezes. Try with the road network from http://download.geofabrik.de/europe/liechtenstein.html for example. I have attached a simple model.

the point is that that green arrow serves to run the tool/model iterating all input features. If input features are a lot the preparation phase take a long, it you leave it do its thing long enough at same point the tool/model starts.

Also available in: Atom PDF