Bug report #16275

The variables pane of composer item is always empty and read only

Added by Andrey Maiorov over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.18.4 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24185

Description

The variables pane of composer item is always empty and read only.

variable_empty.png (3.99 KB) Harrissou Santanna, 2017-03-03 07:47 AM

IMG_0515.PNG - See the screenshot (216 KB) Andrey Maiorov, 2017-03-05 12:19 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

Could you please set the proper category and platform/version when filing tickets? thanks.

#2 Updated by Andrey Maiorov over 3 years ago

Sorry, but I can't edit my ticket.
Please update it:
Category: Map Composer / Printing
Platform: Win x64
Platform version: 7

#3 Updated by Harrissou Santanna over 3 years ago

  • File variable_empty.png added
  • Category set to Map Composer/Printing
  • Operating System set to Windows

I can confirm on a Windows 10 too: none of the Items in print composer has its variables frame populated (see screenshot)

#4 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Open to Feedback

I cannot confirm on Win7 and Linux.

#5 Updated by Nyall Dawson over 3 years ago

Can't confirm on windows either (and I use this feature all the time with multiple different projects). Might be a plugin issue? How was the composition created?

#6 Updated by Harrissou Santanna over 3 years ago

I now can confirm on a ubuntu 16.04 that has no relation with the Windows computer. Surprisingly, it's with a build of master while on the same computer, 2.18.4 doesn't have this issue.

Might be a plugin issue?

I have no plugin installed for QGIS 3

How was the composition created?

As usual, click on "New composer" icon.
Did you try on an empty

#7 Updated by Nyall Dawson over 3 years ago

Can't reproduce on any platform or qgis version!

Please provide step by step instructions on how to reproduce, or a screencast...

#8 Updated by Andrey Maiorov over 3 years ago

#9 Updated by Andrey Maiorov over 3 years ago

Add and delete buttons in variables pane are disabled.

#10 Updated by Giovanni Manghi over 3 years ago

Andrey Maiorov wrote:

Add and delete buttons in variables pane are disabled.

with any project, even starting from scratch? any specific step to replicate?

#11 Updated by Andrey Maiorov over 3 years ago

No any specific steps to reproduce. I am create empty project and then create composer with empty title. Then i'm add the text item to layout. That's all: variables pane of the text item is empty and read only.

#12 Updated by Giovanni Manghi over 3 years ago

Tested again on 3 different opearating systems, no problems whatsoever here.

At this point a screencast would help... but all points to be a local issue.

#13 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Closing for lack of feedback, please reopen of necessary.

Also available in: Atom PDF