Bug report #16188

osgeo64/processing: bag magic number in yaml

Added by Richard Duivenvoorde almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Windows Package
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24098

Description

Just installed current dev version (bb2a6c8) on Windows here (next to 2.14) which fails to start processing because of
ImportError: bad magic number in 'yaml': b'\\x03\\xf3\
\
'
see screendump

FYI: this is 64bit Windows Server 2008 R2 Enterprise install

fout.png - processing stacktrace (36.8 KB) Richard Duivenvoorde, 2017-02-13 11:46 PM

History

#1 Updated by Nyall Dawson over 2 years ago

  • Category changed from Processing/Core to Windows Package
  • Assignee changed from Victor Olaya to Jürgen Fischer

Reassigning to Jürgen- this seems an error in the yaml package itself, not in processing.

#2 Updated by Jürgen Fischer over 2 years ago

Not reproducable here. Apparently it's a stale pyc. Is python3-pyyaml installed? qgis-dev depends on it.

#3 Updated by Jürgen Fischer over 2 years ago

  • Status changed from Open to Feedback

#4 Updated by Nyall Dawson over 2 years ago

Ok - confirmed. Removing all .pyc files from the osgeo4w folder and restarting fixed this for me.

#5 Updated by Richard Duivenvoorde over 2 years ago

Thanks for looking into it. I cannot confirm untill next week when I'm working on that machine again.

So this is a left over from a qgis.2x run in the same folder?
Could be because I installed from an excisting osgeo4w install/folder.

What I'm curious now for is if this could also happen when you install both 2.x and 3/2.99 in same osgeo4w64 folder and first run 2.x (generating .pyc files) and then try to run 3 (picking up those files?)...

Feel free to close it, I will open it when it does not fix my problem.

#6 Updated by Jürgen Fischer over 2 years ago

Richard Duivenvoorde wrote:

So this is a left over from a qgis.2x run in the same folder?

The python3 and python2 installs are different directories. Interesting would be which file it actually is.

What I'm curious now for is if this could also happen when you install both 2.x and 3/2.99 in same osgeo4w64 folder

That should work.

#7 Updated by Jérôme Guélat over 2 years ago

I had the same problem... Deleting C:\\OSGeo4W64\\apps\\qgis-dev\\python\\yaml\\__init__.pyc seemed to help...

Is it safe to remove it?

#8 Updated by Jürgen Fischer over 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Jérôme Guélat wrote:

I had the same problem... Deleting C:\\OSGeo4W64\\apps\\qgis-dev\\python\\yaml\\__init__.pyc seemed to help...

Is it safe to remove it?

Yes - that's from an previous python2 based qgis-dev. Fixed in 702d4cc1.

#9 Updated by Richard Duivenvoorde over 2 years ago

Yep, confirmed here too. Removed all *.pyc files and works!

Also available in: Atom PDF