Bug report #1618

color table for GRASS rasters

Added by Paolo Cavallini over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11678

Description

Newly created GRASS rasters do not get a color table assigned, and no choice is given to the user as to which color table to assign. As a result, one has to load the raster, assign a color table to it, and refresh the canvas to show the new colors. Quite boring and cumbersome for serious work.

History

#1 Updated by Paolo Cavallini over 11 years ago

See also #408, an old bug

#2 Updated by Maciej Sieczka - over 11 years ago

The reason is that some GRASS modues (e.g. r.mapcalc) don't create a color table for their output rasters.

If a GRASS display module encounters such a raster it defaults to 'rainbow' colortable.

Should QGIS do the same?

#3 Updated by Paolo Cavallini over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1207

#4 Updated by Anonymous over 11 years ago

Milestone Version 1.0.2 deleted

Also available in: Atom PDF