Bug report #1616

v.kernel and r.surf.fractal overwriting and not showing results

Added by Paolo Cavallini over 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11676

Description

Several modules (I found v.kernel and r.surf.fractal) don't check if a layer exist before overwriting it. When the analysis is finished, the same modules do not show the "Show output" button, so to load a raster one has to go back to data browser.

History

#1 Updated by Lorenzo Masini over 11 years ago

Please report in the grass bugtracker.

#2 Updated by Paolo Cavallini over 11 years ago

It appears to be a GRASS, not a QGIS, bug

#3 Updated by hamish - over 11 years ago

Replying to pcav:

Several modules (I found v.kernel and r.surf.fractal) don't
check if a layer exist before overwriting it.

r.surf.fractal apparently fixed in svn some months ago, v.kernel currently not.

see https://trac.osgeo.org/grass/ticket/635

When the analysis is finished, the same modules do not show
the "Show output" button, so to load a raster one has to go
back to data browser.

no idea about that part of it.

Hamish

#4 Updated by Paolo Cavallini over 11 years ago

Thanks Hamish. So I assume r.surf.fractal is fixed in grass64rc>=4, right?
Would it be possible to fix in the same way also v.kernel, perhaps before grass64 final?

#5 Updated by hamish - over 11 years ago

Replying to [comment:4 pcav]:

Thanks Hamish. So I assume r.surf.fractal is fixed in grass64rc>=4, right?

It should be fixed since 6.4.0RC1 (Xmas 2008).
Does it still fail with the latest QGIS build?

Would it be possible to fix in the same way also v.kernel,
perhaps before grass64 final?

v.kernel is a bit more tricky because of the funky way it reuses the same option for both raster and vector output map names. I don't think it is too hard to manually code around that (probably can reuse some code from other modules) but someone else will have to do it -- I'm stretched rather thin with my "real-life" job right now, and that has to take precedence.

regards,
Hamish

#6 Updated by Giovanni Manghi almost 11 years ago

Hi, has v.kernel been fixed since the last comment?

cheers

#7 Updated by Redmine Admin over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF