Bug report #16116

QGIS crashes on some ArcGIS FeatureServer layers

Added by Bartosz Perepeczo over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/ArcGIS
Affected QGIS version:2.18.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:24028

Description

QGIS Desktop and QGIS Browser both load layers properly, but crash/freeze forever when there is viewport manipulation (pan/zoom etc) on those particular services:

http://services6.arcgis.com/uWTLlTypaM5QTKd2/ArcGIS/rest/services

one, fairly simple and small, good to test would be:

http://services6.arcgis.com/uWTLlTypaM5QTKd2/ArcGIS/rest/services/nta_transport/FeatureServer/2

As a note they work fine when viewed in ArcGIS online map browser.

I believe there is something wrong with all of those, as other seem to work fine. For example this one works fine for me:

http://services.arcgis.com/P3ePLMYs2RVChkJx/arcgis/rest/services/USA_Senate/FeatureServer

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to High

#2 Updated by Giovanni Manghi over 3 years ago

  • Category set to 148

#3 Updated by Giovanni Manghi over 3 years ago

  • Category changed from 148 to Web Services clients/ArcGIS

#4 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#5 Updated by Giovanni Manghi over 3 years ago

  • Description updated (diff)
  • Status changed from Open to Feedback

http://services6.arcgis.com/uWTLlTypaM5QTKd2/ArcGIS/rest/services/nta_transport/FeatureServer/2

is no more available. Other layers on the same service are working just fine. Please try a more recent version (2.18.7) and report back. Thanks.

#6 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

Closing for lack of feedback.

Also available in: Atom PDF