Bug report #16063

Gdal2tile not opening in Processing

Added by matteo ghetta almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:Alexander Bruy
Category:Processing/GDAL
Affected QGIS version:master Regression?:No
Operating System:Linux mint Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23978

Description

gdal2tile algorithm does not open in Processing due to this error:

File "/home/matteo/lavori/QGIS/build-qgis3/output/python/plugins/processing/gui/MultipleInputPanel.py", line 63, in setSelectedItems
self.tr('%d elements selected') % len(self.selectedoptions))
TypeError: object of type 'int' has no len()

Related to the closed PR https://github.com/qgis/QGIS/pull/3894/

Associated revisions

Revision 6214d4d4
Added by Alexander Bruy almost 3 years ago

[processing] fix wrong parameter definition (fix #16063)

History

#1 Updated by Alexander Bruy almost 3 years ago

It has no relation to this PR. This bug related to parameters refactoring.

#2 Updated by Alexander Bruy almost 3 years ago

  • Status changed from Open to Closed

#3 Updated by matteo ghetta almost 3 years ago

Thanks Alex!

Also available in: Atom PDF